Skip to main content
Training
DifficultybeginnerAdded2027.0Statusdraft

Corridor Quantities (applicable for roads)

Create Datum Surface from Corridor

A Datum surface should be created from the corridor before attempting to do volume calculations.

A Datum surface follows the finished grade on unpaved portions and the subbase on paved portions, going from the left daylight point to the right daylight point. It represents the grading elevations before pavement materials are applied. Datum surfaces are used for calculating the cut and fill quantities.

  1. In the Corridor Properties, go to the Surfaces tab, click on the first icon from the left-hand side, add Datum to the surface name, and set the Overhang Correction to Bottom Links:

  2. Select Links as the Data Type, select Datum for the code and click on the "Plus" sign to add the links to the surface definition:

  3. Go to the Boundaries tab to set the corridor surface's boundary. Right-click on the surface name and use the Corridor extents as outer boundary option:

Note: In some cases, the Corridor extents as outer boundary option might not work, use the other options (Add Automatically, Add Interactively and From Polygon) to create the surface boundary.

Corridor datum surface displayed as triangles:

A corridor surface has very similar properties to a TIN surface, the style can be changed as needed. The image below displays the datum surface contours:

Cut and Fill Quantities (volume)

  1. Before the datum surface can be used for volume calculations, it needs to be sampled. In the Sample Line Group Properties, go to the Sections tab and click on the Sample more sources button:

  2. Select the datum surface in the Available Sources window and click Add:

  3. Change the surface style to Datum (this step is not necessary for volume calculations it is just for styling purposes):

  4. Go to the Material List tab and click on the Import another criteria button to specify the surfaces for cut and fill calculations:

  5. Use Cut-Fill as the Quantity Take of Criteria:

  6. Specify the NGL and datum surfaces:

  7. The cut and fill are defined automatically. The Cut is below the NGL and above the datum surface and the Fill is above the NGL and below the datum surface, see the image below:

  8. Once you click OK the cut and fill quantities are calculated. To display a total volume table in the plan view, go to the Annotate tab and select the Add Tables – Volume – Total Volume command:

  9. Specify the Table style, alignment, sample line group and material list:

Total volume table (cut and fill quantities):

Cut and Fill Quantities with Topsoil Stripping (volume)

Most road projects require topsoil stripping therefore it is necessary to calculate these quantities and incorporate it in the cut/fill quantities. When the road is in a cut condition, the topsoil stripping volume must be subtracted from the bulk earthworks and when the road is in a fill condition, the topsoil stripping must be added to the bulk earthworks. The workflow below shows how to calculate topsoil stripping quantities and how to calculate the appropriate cut and fill quantities including the topsoil stripping.

Topsoil Stripping Subassembly

  1. In the Home tab open the Subassembly tool palette.

  2. Go to the Daylight tab and select the Stripping Pavement subassembly:

  3. Specify the Stripping Depth and other parameters. If you set Extend to Existing Ground to No, then Fore slope and Back slope parameters are not applied:

  4. Add the stripping pavement subassembly to all the daylight subassemblies. If a Conditional Cut or Fill subassembly is used, then all the daylight subassemblies must have the Stripping Pavement subassembly attached:

An example assembly with the Conditional Cut or Fill subassembly and Stripping Pavement subassembly:

  1. Go to the Corridor Properties, Parameters tab and click on the Set all Targets button:

  2. Set the Target Surface for the Stripping Pavement subassembly:

  3. Rebuild the corridor and open the Corridor Properties again. Go to the Surfaces tab, create a new surface and add the Stripping link code to the surface definition:

  4. Add a boundary to the stripping surface (use Corridor extends as outer boundary or any other suitable option):

Calculating Cut and Fill Quantities with Topsoil Stripping

  1. Go to Toolspace – Prospector – Alignments – Centerline Alignments – Sample Line Groups, right-click on the sample line group name and select Properties from the menu**:**

  2. Go to the Material List tab and select Import Another Criteria.

  3. Import Cut | Fill Criteria and specify the stripping surface as the EG and the road datum surface under DATUM:

The result will be as follows:

  1. The style of the cut and fill can be set in the Sections tab in the Sample Line Group Properties.

The image below shows the calculated cut area with the topsoil stripping excluded:

The image below shows the calculated fill area with the topsoil stripping included:

Note: When the road is in a cut condition, additional fill is wrongly calculated. This is a very small quantity and will result in a small discrepancy in the results which can be disregarded at this stage until a more accurate workflow is in place.

  1. To display a total volume table in the plan view, go to Annotate in the ribbon and use the Add Tables – Volume – Total Volume command:

  2. Specify the Table style, alignment, sample line group and material list:

Total volume table (cut and fill quantities):

Calculating the Topsoil Stripping Volume

  1. Go to Toolspace – Prospector – Alignments – Centerline Alignments – Sample Line Groups, right-click on the sample line group name and select Properties from the menu:

  2. In the Material List tab, select Add New Material and specify the name (example below uses the name Topsoil Stripping).

  3. Set the Quantity type to Cut and Refill and add the NGL surface and Stripping Surface to the Topsoil Stripping material.

  4. Change the conditions of the Topsoil stripping material to be Below NGL and Above the Stripping Surface.

  5. Click OK to calculate the quantities. The style of the topsoil stripping area can be changed in the Sections tab of the Sample Line Group Properties.

The topsoil stripping area is hatched using red in the image below:

  1. To display a volume table in the plan view, go to Annotate in the ribbon and use the Add Tables – Volume – Material Volume command:

  2. Specify the Table style, alignment, sample line group and material list:

Material volume table for topsoil stripping:

Layerworks Quantities (volume)

The following method can be used for layerworks' quantities and any other corridor shapes like barriers, kerbs, sidewalks, etc.

  1. Go to the Sample Line Groups Properties, Material List tab and click on the Add new material button:

  2. Specify the material name. For the Quantity Type use Structures, this means the subassembly shapes can be used for calculations. For the Data Type use Corridor Shape and select the corridor shape to be used for specific layer quantities. Follow the steps above for all the layerwork quantities:

  3. Once you click OK the material quantities are calculated. To display a volume table in the plan view, go to the Annotate tab and select the Add Tables – Volume – Material Volume command:

  4. Specify the Table style, alignment, sample line group and material list:

Material volume table for asphalt layer:

Generate a Volume Report

Quantities can be exported to an html format and then copied to any tabular editor (MS Excel, Open Office Calc).

  1. Go to the Analyse tab in the ribbon and select the Volume Report command:

  2. Specify the alignment, sample line group, material list and click on the folder icon to browse for a sheet style:

Default Autodesk Civil 3D contains three sheet styles: Earthwork, Mass Haul – Multiple Materials and Select Material. If you have Devotech iDAS installed, two additional reports are available, see the Reports chapter for details. The Earthwork sheet is suitable for cut and fill quantities, the Select Material sheet is suitable for total material volumes:

  1. When you click OK in the Report Quantities window, Internet Explorer might ask if you want to run a script. Click Yes to create the report:

Earthwork report:

Select Material report:

Below are report examples available in Devotech iDAS.

Devotech Material Report – Grouped:

Devotech Material Report – Separate:

Display Materials in the Cross-sections

  1. All calculated materials can be displayed in the cross-sections. Go to the Sample Line Group Properties, Sections tab and set the style for all the calculated materials:

Cross-section with cut and fill displayed:

Note: If the materials should not be visible, set the material style to _No Display:

Guardrail and Drainage Quantities (length)

The workflow below describes the quantities for guardrails, the same steps can be used for drainage or any other feature line length quantities. These quantities can be calculated with the Civil 3D quantity take-off tools. When using these tools, a pay item file needs to be created first. A pay item file is a .csv file which lists item ID's, Descriptions and Units.

  1. Create a new spreadsheet (use Open Office Calc or MS Excel) and save it as a .csv file (comma delimited). Specify columns with the following headings and add values (one pay item file can contain multiple pay items each item must have a unique ID):

  2. Go to the QTO Manager in the Analyze tab:

  3. Click on the dropdown arrow and select the Open pay item file command:

  4. Click on the envelope next to the pay item file field and browse for the .csv file:

The guardrails pay item appears in the QTO Manager:

  1. The pay item needs to be referenced in the the corridor code set style. Go to Toolspace – Settings − General − Multiprupose Styles − Code Set Style, right-click on the Corridor code set style and use the Edit command from the menu:

  2. Go to the Codes tab in the Code Set Style window, and click on the plus sign next to Point:

  3. Assign the guardrails ID number to the codes Guardrail_L and Guardrail_R:

  4. Close the code set style and rebuild the corridor. Go to the Analyze tab and select the Takeoff command:

  5. Choose Summary or Detailed for the Report type. Set the Report extents to Drawing (users also have the option to calculate the quantity over an alignment station range) and click Compute:

  6. Change the view to Summary (HTML).xsl to view the Quantity Takeoff Report:

  7. If the Detailed report option was selected, change the view to Detailed Linear (HTML).xsl to view the Quantity Takeoff Report:

  8. The Draw button can be used to place a static table in the drawing: